Editor Gráfico

O "Editor de Aplicações Gráficas – EAG" tem por finalidade a criação, visualização e edição de desenhos. Muitas das funções do Editor substituem o trabalho realizado nas antigas pranchetas de desenho.

O EAG não se restringe à edição gráfica de desenhos. Por ser um componente modular e programável dos sistemas TQS®, diversos aplicativos foram desenvolvidos tendo como base o Editor, orientados para tarefas específicas como, por exemplo:

  • Criação de detalhes, desenhos adicionais e construções auxiliares do Modelador Estrutural;
  • Edição de plantas de formas;
  • Edição de armaduras de vigas, pilares, lajes, fundações e outros elementos estruturais;
  • Edição de grelhas;
  • Visualização espacial de geometria, carregamentos, esforços e deslocamentos de grelhas e pórticos;
  • Edição gráfica orientada de esforços com detalhamento automático de armaduras de lajes, vigas e pilares;
  • Projeto de lajes protendidas;
  • Edição de layout de plantas para plotagem;
  • Projeto de alvenaria estrutural;
  • Montagem de máscaras de desenho paramétrico;

O chamado ‘módulo básico’ do Editor, ou Editor Gráfico Básico, contém uma série de menus e barras de ferramentas padrão. As aplicações que usam o Editor acrescentam novos menus e barras de ferramentas ao módulo básico. Este manual descreve o módulo básico do EAG, que permite:

  • Criar desenhos novos e editar desenhos existentes;
  • Criar linhas, poligonais, textos, arcos, círculos, curvas e blocos (agrupamento de outros elementos);
  • Criar bibliotecas de símbolos (blocos), que funcionam como gabaritos de desenho;
  • Quebrar um desenho em partes, misturar desenhos;
  • Controlar escalas, cores, agrupamento de elementos por níveis de desenho;
  • Mover, copiar, apagar, cortar, escalar, espelhar, rodar, limpar intersecções, tirar paralelas, arredondar cantos, etc.;
  • Fazer cotagem semi-automática;
  • Desfazer e/ou refazer um número ilimitado de operações gráficas realizadas por engano;
  • Listar elementos gráficos e propriedades geométricas;
  • Abrir múltiplos desenhos simultaneamente, e transferir informações entre eles;
  • Imprimir desenhos em impressora e plotter; visualizar previamente como ficarão os desenhos impressos;
  • Inserir desenhos "raster" – extensão .BMP e .JPG.

Os aplicativos desenvolvidos com base no Editor têm sua própria documentação. Para usar estes aplicativos, você primeiro precisa conhecer o módulo básico.

Os desenhos manipulados pelo EAG podem ser plotados na impressora ou plotter, em qualquer escala. Mostraremos abreviadamente a plotagem de desenhos. A documentação completa, inclusive sobre montagem de plantas está no manual "TQS® - Edição de Plantas e Plotagem."

O padrão de desenho gerado pelo EAG pode ser facilmente transportado para outros editores gráficos, através de conversores disponíveis nos sistemas TQS®.

O que é um desenho?

Um desenho é um conjunto de elementos gráficos, sendo armazenado no computador na forma de um arquivo. Todo desenho recebe um nome, e este nome será o nome do arquivo armazenado no disco, mais a extensão .DWG.

Ao iniciarmos uma edição, teremos duas opções: editar um desenho existente ou criar um desenho novo.

A maneira mais fácil de editar um desenho existente é selecionando o desenho no painel direito do gerenciador TQS® e apertando o botão "Edição Gráfica". O Editor será chamado e o desenho selecionado aparecerá na tela

86435f1a60e13f811c9d537219e08bfa.png

A segunda maneira é chamando o Editor, através do menu "Visualizar" – "Edição Gráfica" do Gerenciador. Neste caso, o Editor entrará sem nenhum desenho editado. Você precisa acionar o comando "Arquivo" – "Abrir" para abrir um desenho existente, selecionando de uma lista onde você vê previamente o conteúdo de cada desenho.

O desenho é editado na memória

A edição pode ser de um desenho existente ou não, mas será feita sempre na memória do computador (memória que se apaga quando o computador é desligado). Se o desenho já existia, ele é carregado na memória e editado, se não existia, um espaço novo na memória é aberto para a sua criação.

Se houver pane no computador enquanto você está editando um desenho, todo o trabalho desde o início da edição poderá ser perdido. Você sempre deve salvar o desenho.

Para salvar o desenho, você pode utilizar o comando "Arquivo" – "Salvar". Se o desenho já existia, ele será simplesmente copiado da memória para o disco. Se for um desenho novo, seu nome aparece na tela como "sem_nome", e o Editor lhe pedirá para fornecer um.

Existe ainda a opção de auto-salvamento de desenhos. Veja no manual ‘TQS® - Manual de Comandos e Funções Gerais’ como acionar esta opção.

Arquivo .BAK

Todo desenho tem um nome qualquer e tipo .DWG Cada vez que um desenho é salvo no disco, o Editor verifica primeiro se um arquivo com o mesmo nome já existe. Ele sempre existirá se você editar um desenho existente.

O arquivo existente é então renomeado, mantendo o nome inicial, mas mudando o tipo do arquivo para .BAK. Este é um arquivo de backup com o desenho no estado antes da edição. Por exemplo, o arquivo de desenho TESTE.DWG, depois de modificado terá a cópia anterior com o nome TESTE.BAK.

Se você conscientemente fez uma modificação desastrosa e salvou o desenho, basta renomear o arquivo .BAK para um tipo .DWG. Mas apenas uma cópia anterior deste desenho é salva, pode não ser a que você deseja se você editou e salvou várias vezes durante a edição.

O arquivo .BAK tem por objetivo a recuperação de pequenos desastres. Ele não o ajudará se você perder o disco rígido inteiro. Para evitar que isto aconteça, salve frequentemente os seus dados em outro meio físico.

A tela do Editor Gráfico

Veja a tela do Editor e seus elementos principais:

49cdffa7151d8647856e283c35c6a6e3.gif

ItemDescrição
Título da janela com o nome do desenhoContém o nome do desenho atual sendo editado.
Fechar o EditorO meio mais rápido de fechar todos os desenhos e sair do Editor. Equivale ao comando "Arquivo", "Sair".
Fechar o desenhoO meio mais rápido de fechar um desenho. Equivale ao "Arquivo", "Fechar".
Menu suspensoMenu que contém todos os comandos do Editor.
Barras de ferramentasBotões com os comandos mais usados. Reproduz funções do menu.
Janela ou vista de desenhoÁrea onde é feito o desenho. O Editor pode manter múltiplas janelas e múltiplos desenhos simultaneamente abertos.
Janela de mensagensÁrea onde o Editor emite mensagens e onde se digitam coordenadas.
Janela de ajuda adicionalÁrea onde o Editor emite mensagens adicionais para a execução dos comandos.
Ajuda de menuQuando você percorre os menus com o cursor, uma ajuda de cada comando aparece nesta área.
Linha de statusVisualização de vários modos mantidos pelo Editor: nível, cor, travamento, etc.

Coordenadas

Todas as entidades de desenho (linhas, textos, etc.) são armazenadas com coordenadas fixas em relação a um sistema de eixos cartesianos. Isto cria um conceito de desenho diferente do desenho feito a mão:

  • No desenho a mão, você escolhe uma escala razoável e posiciona o desenho na folha de acordo com um layout estudado, de modo a aproveitar melhor o papel;
  • No desenho por computador, você também escolhe uma escala, mas desenha em unidades 1:1. O desenho é colocado em qualquer lugar do plano X-Y. O posicionamento na folha de desenho é feito apenas na etapa de plotagem, e independe das coordenadas usadas no desenho.

Uma folha de desenho feita por computador pode ser composta por um ou mais arquivos de desenho, cada arquivo com o seu próprio sistema de coordenadas e escala. A montagem dos desenhos na folha é feita através do Editor de Plantas. O funcionamento do Editor de Plantas é mostrado no manual ‘TQS - Edição de Plantas e Plotagem’.

Unidades e Escala

Quando um desenho é feito a mão, escolhe-se uma escala de trabalho, e todas as medidas de desenho correspondem a uma determinada unidade de trabalho, dividida pela escala. A divisão das medidas pela escala é obrigatória, para que o desenho caiba no papel.

No computador, o desenho é feito sobre um plano imaginário, de comprimento infinito. Não há necessidade de conversão de escalas durante o ato de desenhar; geralmente é preferível fazer o desenho com medidas na escala 1:1. Estas medidas podem estar na unidade mais conveniente. Nos sistemas TQS®, a grande maioria dos desenhos utiliza centímetros.

A conversão de escala é feita somente quando o desenho estiver pronto. Armazenado em disco, o desenho é enviado para plotagem em impressora ou plotter. Ao plotar, informamos ao sistema o Fator de Escala:

Todas as medidas do desenho, divididas pelo fator de escala resultam em centímetros no papel de plotagem.

Se a unidade de desenho é centímetros, para plotarmos em escala 1:50 usaremos um fator de escala 50, de modo que cada de desenho resultarão em 100/50 = no plotter. Se o mesmo desenho tiver unidade em metros, o fator de escala será 0.5, pois dividido por 0.5 resultará nos mesmos .

Veja alguns exemplos de desenhos com unidades e escalas diferentes, e o fator de escala fornecido:

Unidade de desenhoEscala desejadaFator de escalaCentímetros de plotagem por unidade
Metros1:500.52.000
Centímetros1:5050.0.0200
Polegadas1:5019.680.0508

Escala aplicada ao texto

Aparentemente um desenho feito por computador poderia, a qualquer momento, ser plotado em qualquer escala. Isto vale para desenho de linhas, mas não é verdadeiro para desenho de textos e anotações em geral.

Suponha que num desenho em escala 1:50 os textos sejam perfeitamente legíveis, e saiam desenhados com tamanho final de . Se plotarmos novamente o desenho, mas com escala 1:100, o desenho será reduzido para a metade, inclusive os textos. O texto que tinha tamanho de passará a ter apenas , tornando-se ilegível. A mudança de escala provocou o mesmo efeito de uma redução com máquina Xerox.

Os textos colocados no desenho são totalmente dependentes da escala, o que torna o planejamento inicial de escala obrigatório. A escala deve ser definida antes de se iniciar o desenho, para que o tamanho dos textos possa ser dimensionado.

O EAG mantém na memória o fator de escala, e automaticamente multiplica os textos por este fator. Você deve fornecer sempre os tamanhos de texto em centímetros, no tamanho que sairão no papel. Suponha que você tenha 2 desenhos, em escala 1:50 e 1:100. O EAG fará as seguintes contas quando você quiser plotar textos com de altura:

EscalaFator de escalaTamanho fornecido do textoTamanho armazenado pelo EAGDividido pelo fator de escala durante a plotagem
1:5050.0.210.0.2
1:100100.0.220.0.2
1:5050.0.210.0.2

Dentro do EAG, o fator de escala é uma das propriedades de desenho. Veja adiante a sua definição.

A visualização do desenho na tela é independente da escala de plotagem. Dentro do EAG, o desenho é visto em qualquer tamanho e detalhe, conforme as necessidades de edição. Os textos assumirão proporções diferentes, conforme a escala de desenho planejada para plotagem, como na figura:

a8ce1b3aeaaf9d9827e24316f21970ab.png

Como o tamanho do desenho na tela não dá noção do tamanho real, um erro na escolha de escala pode não ser detectado a priori. Por isto, tenha sempre em mente a escala de desenho em que está trabalhando.

A janela de visualização

Os elementos gráficos de um desenho têm coordenadas de um plano cartesiano. A tela do computador representa uma janela neste plano. Assim, é possível que elementos de desenho estejam fora da tela em um determinado instante:

5e3e5b3faf7ce49a559153e912b1767e.png

Nada impede que parte ou todo o desenho (como no exemplo acima) estejam fora da janela de visualização do Editor. Neste exemplo, a tela ficará vazia, apesar de existir uma planta de formas desenhada. A janela do Editor pode não apenas estar em qualquer lugar, mas ter qualquer tamanho (isto é, qualquer escala).

Esta pode ser uma dificuldade para quem está começando a usar o Editor, pois se as coordenadas da janela atual não forem conhecidas, um elemento desenhado em coordenadas quaisquer poderão não aparecer na tela imediatamente. Assim, sugerimos que ao começar um desenho novo:

  • Faça o desenho de um retângulo envolvente do seu desenho, fornecendo as coordenadas exatas do retângulo;
  • Usando o menu de comandos de janela, acione o comando de "Janela total", para que o Editor monte uma janela suficientemente grande, e em posição para visualizar o retângulo inserido.

673b71f0d215c6bad5005b9aa8323e86.png

Múltiplos desenhos simultâneos

O EAG tem capacidade de edição simultânea de múltiplos desenhos. Depois que você abrir um desenho, ele será fechado apenas quando você mandar - através do comando "Arquivo" "Fechar", ou saindo do Editor. Se você mandar abrir outro desenho, dois desenhos ficarão abertos simultaneamente, e assim por diante. Cada um dos desenhos abertos será fechado no final, de maneira explícita, ou com a saída do Editor. Veja no canto direito superior da tela de edição, que um dos "X" fecha o Editor, enquanto outro fecha o desenho atual.

Existem vários motivos para manter desenhos abertos. Você pode olhar para um desenho e tomar outro como referência, ou transferir partes de um desenho para outro. Veja no capítulo de "Controle de Visualização" como manter várias vistas abertas, e no capítulo de edição sobre o uso da área de transferência do Windows®.

Motor Gráfico 3D

A partir da versão V22 dos sistemas TQS foram desenvolvidos novos editores gráficos passando a ser em 3D e os editores em 2D foram mantidos, para alterar entre os modos gráficos 2D e 3D siga o seguinte passo-a-passo:

  • No Gerenciador TQS clique em "Ferramentas" - "Configurações" - "Edição gráfica";
  • No item "Saída gráfica" clique em "Editores gráficos" e escolha o modo.

Vale ressaltar que o motor gráfico dos editores gráficos 2D e 3D foram completamente remodelados, tendo um grande aumento de desempenho reduzindo em até 50% do tempo de display.